Need Help?
GETTING STARTED

Before you begin using the EYE OF THE STORM website, we recommend using the following browser:

Netscape Communicator 6.2.3 or higher
Internet Explorer 5.x or higher

We also recommend that you take the time to aquire the following plug-ins to make your stay here truely interactive and dynamic.

QuickTime
Flash


Note: All of the above items are FREE!